Adobe Flash Player < 32.0.0.101 Multiple RCE (APSB18-42)

high Nessus Network Monitor Plugin ID 700375
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is running an outdated version of Adobe Flash Player that is affected by multiple attack vectors.

Description

Versions of Adobe Flash Player prior to 32.0.0.101 are unpatched, and therefore affected by the following RCE vulnerabilities :

- An unspecified use-after-free error exists that allows remote code execution. (CVE-2018-15982)
- An unspecified insecure library loading error exists that allows privilege escalation. (CVE-2018-15983)

Solution

Upgrade to Adobe Flash Player version 32.0.0.101 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb18-42.html

Plugin Details

Severity: High

ID: 700375

Family: Web Clients

Published: 12/5/2018

Updated: 3/6/2019

Dependencies: 5158

Risk Information

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:adobe:flash_player:*:*:*:*:*:*:*:*

Patch Publication Date: 12/5/2018

Vulnerability Publication Date: 12/5/2018

Reference Information

CVE: CVE-2018-15982, CVE-2018-15983