Mozilla Firefox < 58.0.1 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 700327

Synopsis

The remote host has a web browser installed that is vulnerable to multiple attack vectors.

Description

Versions of Mozilla Firefox earlier than 58.0.1 are unpatched for the following vulnerabilities :

- A flaw exists in the browser UI that is triggered when handling specially crafted HTML fragments. This may allow a context-dependent attacker to potentially execute arbitrary code. (CVE-2018-5124)

Solution

Upgrade to Firefox version 58.0.1 or later.

See Also

https://www.mozilla.org/en-US/security/advisories/mfsa2018-05

Plugin Details

Severity: High

ID: 700327

Family: Web Clients

Published: 2018/08/21

Updated: 2019/03/06

Dependencies: 9131

Nessus ID: 106561

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2018/01/29

Vulnerability Publication Date: 2018/01/24

Reference Information

CVE: CVE-2018-5124

BID: 102843