Oracle MySQL 5.6.x < 5.6.37 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 700186

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The version of MySQL installed on the remote host is version 5.6.x prior to 5.6.37 and is affected by an unspecified flaw exists that may allow an authenticated remote attacker to cause a denial of service. No further details have been provided by the vendor. (CVE-2017-3635)

Vulnerabilites also exists within the following components :

- Charsets (CVE-2017-3648)
- Client (CVE-2017-3636, CVE-2017-3651)
- DDL (CVE-2017-3652, CVE-2017-3653)
- DML (CVE-2017-3634, CVE-2017-3641)
- Memcached (CVE-2017-3633)
- Replication (CVE-2017-3647, CVE-2017-3649)

Solution

Upgrade to MySQL 5.6.37 or later.

See Also

http://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-37.html

Plugin Details

Severity: High

ID: 700186

Family: Database

Published: 2017/08/24

Modified: 2018/09/16

Dependencies: 8914

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 7.5

Temporal Score: 7.2

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Patch Publication Date: 2017/07/17

Vulnerability Publication Date: 2017/07/17

Reference Information

CVE: CVE-2017-3633, CVE-2017-3634, CVE-2017-3635, CVE-2017-3636, CVE-2017-3641, CVE-2017-3647, CVE-2017-3648, CVE-2017-3649, CVE-2017-3651, CVE-2017-3652, CVE-2017-3653

BID: 99722, 99729, 99730, 99736, 99767, 99789, 99796, 99799, 99802, 99805, 99810