VLC Media Player 2.x < 2.2.5 Multiple RCE

High Nessus Network Monitor Plugin ID 700130


The remote host contains a media application that is affected by multiple Remote Code Execution (RCE) vectors.


The remote host is running VLC 2.x prior to 2.2.5 and is affected by multiple RCE vulnerabilities :

- An overflow condition exists that is triggered as certain input is not properly validated. With a specially crafted AVI file, a context-dependent attacker can cause a heap-based buffer overflow, potentially allowing the execution of arbitrary code. (OSVDB 158159)
- An unspecified flaw exists that is triggered when handling LPCM in VOB files. This may allow a context-dependent attacker to corrupt memory and potentially execute arbitrary code. (OSVDB 158214)


Upgrade to VLC Media Player 2.x version 2.2.5 or later.

See Also


Plugin Details

Severity: High

ID: 700130

File Name: 700130.prm

Family: Web Clients

Published: 2017/06/07

Modified: 2017/06/07

Dependencies: 9797

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 9.6

Temporal Score: 9.1


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Patch Publication Date: 2016/08/29

Vulnerability Publication Date: 2016/08/29

Reference Information

OSVDB: 158159, 158214