The remote host is running a version of Samba server that is affected by a critical Remote Code Execution (RCE) attack vector.
Versions of Samba 4.4.x prior to 4.4.14, 4.5.x prior to 4.5.10, and 4.6.x prior to 4.6.4 are unpatched, and therefore affected by a flaw in the 'is_known_pipename()' function in 'rpc_server/srv_pipe.c' that is due to the program failing to restrict users from accessing files as nt specific pipes. By uploading a shared library to a writable location, this may allow an authenticated, remote attacker to execute arbitrary code with root privileges.
Upgrade Samba to version 4.6.4 or later. If version 4.6.x cannot be obtained, versions 4.5.10, and 4.4.14 are also patched for these issues.