Samba 4.4.x < 4.4.14 / 4.5.x < 4.5.10 / 4.6.x < 4.6.4 RCE (SambaCry)

Critical Nessus Network Monitor Plugin ID 700127

Synopsis

The remote host is running a version of Samba server that is affected by a critical Remote Code Execution (RCE) attack vector.

Description

Versions of Samba 4.4.x prior to 4.4.14, 4.5.x prior to 4.5.10, and 4.6.x prior to 4.6.4 are unpatched, and therefore affected by a flaw in the 'is_known_pipename()' function in 'rpc_server/srv_pipe.c' that is due to the program failing to restrict users from accessing files as nt specific pipes. By uploading a shared library to a writable location, this may allow an authenticated, remote attacker to execute arbitrary code with root privileges.

Solution

Upgrade Samba to version 4.6.4 or later. If version 4.6.x cannot be obtained, versions 4.5.10, and 4.4.14 are also patched for these issues.

See Also

http://www.nessus.org/u?251ce823

https://www.samba.org/samba/history/samba-4.4.14.html

https://www.samba.org/samba/history/samba-4.5.10.html

https://www.samba.org/samba/history/samba-4.6.4.html

Plugin Details

Severity: Critical

ID: 700127

Family: Samba

Published: 2017/05/26

Updated: 2019/03/06

Dependencies: 8741

Nessus ID: 42411

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2017/05/24

Vulnerability Publication Date: 2017/05/24

Exploitable With

Metasploit (Samba is_known_pipename() Arbitrary Module Load)

Reference Information

CVE: CVE-2017-7494

BID: 98636