Samba 4.4.x < 4.4.14 / 4.5.x < 4.5.10 / 4.6.x < 4.6.4 RCE (SambaCry)

critical Nessus Network Monitor Plugin ID 700127
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote host is running a version of Samba server that is affected by a critical Remote Code Execution (RCE) attack vector.


Versions of Samba 4.4.x prior to 4.4.14, 4.5.x prior to 4.5.10, and 4.6.x prior to 4.6.4 are unpatched, and therefore affected by a flaw in the 'is_known_pipename()' function in 'rpc_server/srv_pipe.c' that is due to the program failing to restrict users from accessing files as nt specific pipes. By uploading a shared library to a writable location, this may allow an authenticated, remote attacker to execute arbitrary code with root privileges.


Upgrade Samba to version 4.6.4 or later. If version 4.6.x cannot be obtained, versions 4.5.10, and 4.4.14 are also patched for these issues.

See Also

Plugin Details

Severity: Critical

ID: 700127

Family: Samba

Published: 5/26/2017

Updated: 3/6/2019

Dependencies: 8741

Nessus ID: 42411

Risk Information


Risk Factor: Critical

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:*

Patch Publication Date: 5/24/2017

Vulnerability Publication Date: 5/24/2017

Exploitable With

Metasploit (Samba is_known_pipename() Arbitrary Module Load)

Reference Information

CVE: CVE-2017-7494

BID: 98636