Moodle 3.1.x < 3.1.6 Multiple Vulnerabilities

Critical Nessus Network Monitor Plugin ID 700125

Synopsis

The remote web server is hosting a web application that is vulnerable to multiple attack vectors.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 3.1.x prior to 3.1.6 are affected by multiple vulnerabilities :

- Unspecified flaws exist that may allow an attacker to have an unspecified impact. No further details have been provided by the vendor.
- A flaw exists that may allow an authenticated remote attacker to edit the external blog links of other users. This may allow the attacker to take ownership of arbitrary blogs.
- A flaw exists that is due to a lack of capability checks. This may allow an authenticated remote attacker to search arbitrary blogs.
- A flaw exists as HTTP requests to the 'my/index.php' script do not require multiple steps, explicit confirmation, or a unique token when performing certain sensitive actions. By tricking a user into following a specially crafted link, a context-dependent attacker can perform a Cross-Site Request Forgery (CSRF / XSRF) attack causing the victim to change the number of courses displayed in the course overview block.

Solution

Upgrade to Moodle version 3.1.6 or later.

See Also

https://docs.moodle.org/dev/Moodle_3.1.6_release_notes

Plugin Details

Severity: Critical

ID: 700125

Family: CGI

Published: 2017/05/25

Updated: 2019/03/06

Dependencies: 9398

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2017/05/08

Vulnerability Publication Date: 2017/05/08

Reference Information

CVE: CVE-2017-7489, CVE-2017-7490, CVE-2017-7491

BID: 98463, 98486