CVE-2017-7491

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In Moodle 2.x and 3.x, a CSRF attack is possible that allows attackers to change the "number of courses displayed in the course overview block" configuration setting.

References

https://moodle.org/mod/forum/discuss.php?d=352355

Details

Source: MITRE

Published: 2017-05-15

Updated: 2017-05-23

Type: CWE-352

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Impact Score: 1.4

Exploitability Score: 2.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:moodle:moodle:2.7.0:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.0:beta:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.0:rc1:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.0:rc2:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.1:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.2:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.3:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.4:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.5:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.6:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.7:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.8:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.9:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.10:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.11:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.12:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.13:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.14:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.15:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.16:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.17:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:2.7.18:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.0.0:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.0.0:beta:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.0.0:rc1:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.0.0:rc2:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.0.0:rc3:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.0.0:rc4:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.0.1:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.0.2:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.0.3:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.0.4:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.0.5:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.0.6:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.0.7:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.0.8:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.1.0:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.1.0:beta:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.1.0:rc1:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.1.0:rc2:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.1.1:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.1.2:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.1.3:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.1.4:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.2.0:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.2.0:beta:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.2.0:rc1:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.2.0:rc2:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.2.0:rc3:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.2.0:rc4:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.2.0:rc5:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.2.1:*:*:*:*:*:*:*

cpe:2.3:a:moodle:moodle:3.2.2:*:*:*:*:*:*:*

Tenable Plugins

View all (4 total)

IDNameProductFamilySeverity
700126Moodle 3.2.x < 3.2.3 Multiple VulnerabilitiesNessus Network MonitorCGI
critical
700125Moodle 3.1.x < 3.1.6 Multiple VulnerabilitiesNessus Network MonitorCGI
critical
700124Moodle 3.0.x < 3.0.10 Multiple VulnerabilitiesNessus Network MonitorCGI
critical
700123Moodle 2.7.x < 2.7.20 Multiple VulnerabilitiesNessus Network MonitorCGI
critical