PHP 7.0.x < 7.0.17 / 7.1.x < 7.1.3 DoS

Medium Nessus Network Monitor Plugin ID 700087


The remote web server uses a version of PHP that is affected by a Denial of Service (Dos) attack vector.


Versions of PHP 7.0.x prior to 7.0.17 and 7.1.x prior to 7.1.3 are affected by an error related to handling HTTP POST requests when configured with a large 'post_max_size' that allows DoS attacks via CPU resource exhaustion.


Upgrade to PHP version 7.1.3. If 7.1.x cannot be obtained, 7.0.17 has also been patched for this vulnerability.

See Also

Plugin Details

Severity: Medium

ID: 700087

File Name: 700087.prm

Family: Web Servers

Published: 2017/05/05

Modified: 2017/05/05

Dependencies: 9243

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 3.6

Temporal Score: 3.4


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2017/03/16

Vulnerability Publication Date: 2017/02/10

Reference Information

OSVDB: 151860