Oracle MySQL 5.6.x < 5.6.36 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 700063

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The version of MySQL installed on the remote host is version 5.6.x prior to 5.6.36 and is affected by multiple issues :

- An unspecified flaw exists related to the DML subcomponent. This may allow an authenticated remote attacker to cause a denial of service. No further details have been provided by the vendor. (CVE-2017-3308)
- An unspecified flaw exists related to the Optimizer subcomponent. This may allow an authenticated remote attacker to cause a denial of service. No further details have been provided by the vendor. (CVE-2017-3309, CVE-2017-3452, CVE-2017-3453)
- An unspecified flaw exists related to the Thread Pooling subcomponent. This may allow a remote attacker to cause a denial of service. No further details have been provided by the vendor. (CVE-2017-3329)
- An unspecified flaw exists related to the Memcached subcomponent. This may allow a remote attacker to cause a denial of service. No further details have been provided by the vendor. (CVE-2017-3450)
- An unspecified flaw exists related to the DML subcomponent. This may allow an authenticated attacker to cause a denial of service. No further details have been provided by the vendor. (CVE-2017-3456)
- An unspecified flaw exists related to the Security: Privileges subcomponent. This may allow an authenticated attacker to cause a denial of service. No further details have been provided by the vendor. (CVE-2017-3461, CVE-2017-3462, CVE-2017-3463)
- An unspecified flaw exists related to the DDL subcomponent. This may allow an authenticated attacker to have an unspecified impact on integrity. No further details have been provided by the vendor. (CVE-2017-3464)
- An unspecified flaw exists related to the Pluggable Auth subcomponent. This may allow a remote attacker to cause a denial of service. No further details have been provided by the vendor. (CVE-2017-3599)
- An unspecified flaw exists related to the Client mysqldump subcomponent. This may allow an authenticated attacker to potentially execute arbitrary code. No further details have been provided by the vendor. (CVE-2017-3600)

Solution

Upgrade to MySQL 5.6.36 or later.

See Also

http://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-36.html

Plugin Details

Severity: High

ID: 700063

Family: Database

Published: 2017/04/20

Updated: 2019/03/06

Dependencies: 8914

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 7.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Patch Publication Date: 2017/04/10

Vulnerability Publication Date: 2017/04/18

Reference Information

CVE: CVE-2017-3308, CVE-2017-3309, CVE-2017-3329, CVE-2017-3450, CVE-2017-3452, CVE-2017-3453, CVE-2017-3456, CVE-2017-3461, CVE-2017-3462, CVE-2017-3463, CVE-2017-3464, CVE-2017-3599, CVE-2017-3600

BID: 97725, 97742, 97747, 97754, 97763, 97765, 97776, 97779, 97812, 97818, 97831, 97849, 97851