Apache Tomcat 7.0.x < 7.0.76 / 8.0.x < 8.0.42 / 8.5.x < 8.5.12 / 9.0.0.x < 9.0.0.M18 Information Disclosure

low Nessus Network Monitor Plugin ID 700056
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server is missing an Apache Tomcat patch update.


The version of Apache Tomcat installed on the remote host is version 7.0.x prior to 7.0.76, 8.0.x prior to 8.0.42, 8.5.x prior to 8.5.12, and 9.0.0.x prior to 9.0.0.M18, and is affected by a flaw in the handling of object references that is triggered when calling certain application listeners. With a specially crafted web application, a local attacker may gain access to information associated with another web application.


Update to Apache Tomcat version 9.0.0.M18 or later. If version 9.0.0.x cannot be obtained, 8.5.12, 8.0.42, and 7.0.76 have also been patched for this vulnerability.

See Also




Plugin Details

Severity: Low

ID: 700056

Family: Web Servers

Published: 4/14/2017

Updated: 3/6/2019

Vulnerability Information

Patch Publication Date: 3/13/2017

Vulnerability Publication Date: 2/9/2017

Reference Information

CVE: CVE-2017-5648