Moodle 2.7.x < 2.7.19 RCE

Critical Nessus Network Monitor Plugin ID 700008

Synopsis

The remote web server is hosting a web application that is vulnerable to a Remote Code Execution (RCE) attack vector.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 2.7.x prior to 2.7.19 are affected by a flaw that may allow an attacker to execute arbitrary code.

Solution

Upgrade to Moodle version 2.7.19 or later.

See Also

https://docs.moodle.org/dev/Moodle_2.7.19_release_notes

https://moodle.org/mod/forum/discuss.php?d=349419#p1409805

Plugin Details

Severity: Critical

ID: 700008

Family: CGI

Published: 2017/03/20

Updated: 2019/03/06

Dependencies: 8690

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2017/03/13

Vulnerability Publication Date: 2017/03/13

Reference Information

CVE: CVE-2019-10659