EAServer <= 6.3.1 / 6.2 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 6935

Synopsis

The remote application server is potentially affected by multiple vulnerabilities.

Description

Sybase EAServer versions 6.3.1 and 6.2 are potentially affected by the following three vulnreabilities:

- Directory traversal vulnerabilities due to insufficient user input sanitation in the EAServer redirector plugin, whereby an attacker could list all directories and display arbitrary files on the vulnerable server.

- Directory traversal vulnerability due to insufficient user input sanitation via SOAP requests to the server, whereby an attacker could list all directories and display arbitrary files, or use it in conjunction with other vulnerabilities to execute arbitrary commands on the vulnerable system.

- OS command execution via the WSH service, which can be used in conjunction with the aforementioned vulnerabilities to run arbitrary commands on the vulnerable system.

Solution

Apply the vendor's EBF file relevant for your platform. (Installations earlier than 6.2 may need to upgrade to newer versions before applying the patch.)

See Also

http://www.sybase.com/detail?id=1099353

https://www.sec-consult.com/fxdata/seccons/prod/temedia/advisories_txt/20130719-0_Sybase_Application_Server_Multiple_Vulnerabilities_v10.txt

Plugin Details

Severity: High

ID: 6935

Family: Web Servers

Published: 2013/06/21

Modified: 2016/01/22

Dependencies: 1442

Nessus ID: 67007

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:sybase:easerver

Patch Publication Date: 2013/06/17

Vulnerability Publication Date: 2013/06/19

Reference Information

BID: 60614, 61358

IAVA: 2013-A-0123