PHP 5.4.x < 5.4.17 Buffer Overflow (deprecated)

High Nessus Network Monitor Plugin ID 6929

Synopsis

The remote web server uses a version of PHP that is affected by a buffer overflow vulnerability.

Description

PHP versions 5.4.x earlier than 5.4.17 are affected by the buffer overflow error that exists in the function '_pdo_pgsql_error' in the file 'ext/pdo_pgsql/pgsql_driver.c'

Solution

Upgrade to PHP version 5.4.17 or later.

See Also

http://bugs.php.net/64949

http://www.php.net/ChangeLog-5.php#5.4.17

Plugin Details

Severity: High

ID: 6929

File Name: 6929.prm

Family: Web Servers

Published: 2013/07/16

Modified: 2016/01/15

Dependencies: 8682

Nessus ID: 67260

Risk Information

Risk Factor: High

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2013/07/04

Vulnerability Publication Date: 2013/07/04