cURL/libcURL 'curl_easy_unescape()' Heap Memory Corruption

Medium Nessus Network Monitor Plugin ID 6898

Synopsis

The cURL program is a library and command-line tool for transferring data using various protocols, including HTTP, FTP, and LDAP. A vulnerable version of cURL was detected from the host.

Description

A heap-based buffer overflow flaw was found in the way libcurl unescaped URLs. A remote attacker could provide a specially-crafted URL that, when processed by an application using libcurl that handles untrusted URLs, would possibly cause it to crash or, potentially, execute arbitrary code.

Solution

Upgrade the affected packages; the next version of cURL that fixes the issue is cURL 7.31.0.

See Also

https://www.redhat.com/security/data/cve/CVE-2013-2174.html

http://curl.haxx.se/docs/adv_20130622.html

http://rhn.redhat.com/errata/RHSA-2013-0983.html

Plugin Details

Severity: Medium

ID: 6898

Family: Web Clients

Published: 2013/07/01

Updated: 2019/03/06

Dependencies: 1735, 8314

Nessus ID: 66981

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:haxx:curl

Patch Publication Date: 2013/06/22

Vulnerability Publication Date: 2013/06/22

Reference Information

CVE: CVE-2013-2174

BID: 60737