Flash Player <= 10.3.183.18 / 11.2.202.233 Object Confusion Vulnerability (APSB12-09)

High Nessus Network Monitor Plugin ID 6801

Synopsis

The remote host contains a browser plug-in that is affected by a code execution vulnerability

Description

The remote host has Adobe Flash Player installed.

Versions of Flash Player 10.x equal to or earlier than 10.3.183.18 or 11.x equal to or ealier than 11.2.202.233 are potentially affected by an object confusion vulnerability that could allow an attacker to crash the application or potentially take control of the target system.

By tricking a victim into visiting a specially crafted page, an attacker may be able to utilize this vulnerability to execute arbitrary code subject to the users' privileges

Solution

Upgrade to Flash Player 10.3.183.19 / 11.2.202.235 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb12-09.html

http://www.nessus.org/u?ba4bc112

Plugin Details

Severity: High

ID: 6801

File Name: 6801.prm

Family: Web Clients

Published: 2013/05/08

Modified: 2016/01/19

Dependencies: 1735, 8314

Nessus ID: 58994

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2012/05/04

Vulnerability Publication Date: 2012/05/04

Exploitable With

Metasploit (windows/browser/adobe_flash_rtmp.rb)

Reference Information

CVE: CVE-2012-0779

BID: 53395

OSVDB: 81656