nginx < 1.4.1 / 1.5.0 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 6795


The remote web server is running an outdated version of nginx and is thus affected by several vulnerabilities.


Older versions of nginx are affected by the following vulnerabilities:

- Older versions using proxy_pass can cause denial of service or disclosure of worker process memory. Failed exploit attempts will result in a denial-of-service condition. (CVE-2013-2070)

- A related vulnerability in nginx versions 1.3.9-1.4.0 is a stack-based buffer-overflow vulnerability, due to an error in the 'ngx_http_parse.c' source file. Specifically, this issue occurs in a worker process when handling a specially crafted request. Successfully exploiting this issue allows attackers to execute arbitrary code in the context of the vulnerable application (CVE-2013-2028).


Patches are available and the problem is fixed in nginx versions 1.5.0 and 1.4.1.

See Also

Plugin Details

Severity: High

ID: 6795

Family: Web Servers

Published: 2013/05/08

Updated: 2019/03/06

Dependencies: 1442

Nessus ID: 66672

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Patch Publication Date: 2013/05/07

Vulnerability Publication Date: 2013/05/07

Exploitable With

Metasploit (Nginx HTTP Server 1.3.9-1.4.0 Chunked Encoding Stack Buffer Overflow)

Reference Information

CVE: CVE-2013-2070, CVE-2013-2028

BID: 59699, 59824