nginx < 1.4.1 / 1.5.0 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 6795

Synopsis

The remote web server is running an outdated version of nginx and is thus affected by several vulnerabilities.

Description

Older versions of nginx are affected by the following vulnerabilities:

- Older versions using proxy_pass can cause denial of service or disclosure of worker process memory. Failed exploit attempts will result in a denial-of-service condition. (CVE-2013-2070)

- A related vulnerability in nginx versions 1.3.9-1.4.0 is a stack-based buffer-overflow vulnerability, due to an error in the 'ngx_http_parse.c' source file. Specifically, this issue occurs in a worker process when handling a specially crafted request. Successfully exploiting this issue allows attackers to execute arbitrary code in the context of the vulnerable application (CVE-2013-2028).

Solution

Patches are available and the problem is fixed in nginx versions 1.5.0 and 1.4.1.

See Also

http://seclists.org/oss-sec/2013/q2/290

http://seclists.org/oss-sec/2013/q2/315

http://nginx.org/download/patch.2013.chunked.txt

http://nginx.org/download/patch.2013.proxy.txt

Plugin Details

Severity: High

ID: 6795

Family: Web Servers

Published: 2013/05/08

Modified: 2016/01/15

Dependencies: 1442

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Patch Publication Date: 2013/05/07

Vulnerability Publication Date: 2013/05/07

Exploitable With

Metasploit (Nginx HTTP Server 1.3.9-1.4.0 Chunked Encoding Stack Buffer Overflow)

Reference Information

CVE: CVE-2013-2070, CVE-2013-2028

BID: 59699, 59824