Webmin <= 1.580 Multiple Input-Validation Vulnerabilities (deprecated)

Medium Nessus Network Monitor Plugin ID 6780

Synopsis

nThe remote web server is affected by multiple input-validation vulnerabilities

Description

The remote host is running a Webmin HTTP server.

Versions earlier than or equal to 1.580 are vulnerable to the following vulnerabilities :

- A command execution vulnerability affects the 'edit_mon.cgi' , 'saved_mon.cgi' and '/file/show.cgi' scripts. (CVE-2012-2981, CVE-2012-2982)

- A directory traversal vulnerability affects the 'file' parameter of the 'edit_html.cgi' script. (CVE-2012-2983)

Solution

Upgrade to version 1.590 or greater

See Also

http://www.kb.cert.org/vuls/id/788478

http://www.webmin.com/changes.html

Plugin Details

Severity: Medium

ID: 6780

Family: Web Servers

Published: 2013/05/01

Modified: 2016/01/21

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.5

Temporal Score: 5.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 6.3

Temporal Score: 5.9

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gentoo:webmin

Patch Publication Date: 2013/06/30

Vulnerability Publication Date: 2012/06/09

Exploitable With

Metasploit (Webmin /file/show.cgi Remote Command Execution)

Reference Information

CVE: CVE-2012-2981, CVE-2012-2982, CVE-2012-2983

BID: 55446