VLC Media Player < 2.0.6 ASF Demuxer Buffer Overflow

High Nessus Network Monitor Plugin ID 6778

Synopsis

The remote host contains an application that is affected by a buffer overflow vulnerability

Description

The remote host is running VLC 2.x prior to 2.0.6 and is affected by a a buffer overflow vulnerability related to the ASF demuxer plugin.

Solution

Upgrade to VLC Media Player version 2.0.6 or later.

See Also

http://www.videolan.org/security/sa1302.html

http://www.nessus.org/u?b8052708

http://trac.videolan.org/vlc/ticket/8024a

http://www.videolan.org/vlc/releases/2.0.6.html

Plugin Details

Severity: High

ID: 6778

Family: Web Clients

Published: 2013/04/29

Modified: 2016/01/19

Dependencies: 9797

Nessus ID: 66216

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.3

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Patch Publication Date: 2012/01/17

Vulnerability Publication Date: 2012/01/11

Reference Information

CVE: CVE-2013-1954

BID: 57333