Flash Player <= 10.3.183.29 / 11.4.402.287 Multiple Vulnerabilities (APSB12-24)

High Nessus Network Monitor Plugin ID 6656

Synopsis

The remote host contains a browser plug-in that is affected by multiple vulnerabilities.

Description

The remote host has Adobe Flash Player installed.

Versions of Flash Player 11.x equal to or earlier than 11.4.402.287, or 10.x equal to or earlier than 10.3.183.29 are affected by multiple vulnerabilities:

- Several unspecified issues exist that can lead to buffer overflows and arbitrary code execution. (CVE-2012-5274, CVE-2012-5275, CVE-2012-5276, CVE-2012-5277, CVE-2012-5280)

- An unspecified security bypass issue exists that can lead to arbitrary code execution. (CVE-2012-5278)

- An unspecified issue exists that can lead to memory corruption and arbitrary code execution. (CVE-2012-5279)

Solution

Upgrade to Flash Player 10.3.183.43 / 11.5.502.110 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb12-24.html

Plugin Details

Severity: High

ID: 6656

Family: Web Clients

Published: 2012/12/11

Updated: 2019/03/06

Dependencies: 1735, 8314

Nessus ID: 62836

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2012/12/11

Vulnerability Publication Date: 2012/12/11

Reference Information

CVE: CVE-2012-5274, CVE-2012-5275, CVE-2012-5276, CVE-2012-5277, CVE-2012-5279, CVE-2012-5280

BID: 56542, 56543, 56544, 56545, 56546, 56547, 56554