Apache 2.2 < 2.2.23 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 6576


The remote web server uses a version of Apache that is affected by multiple vulnerabilities


Apache versions earlier than 2.2.23 are affected by the following vulnerabilities.

- The utility 'apachectl' can receive a zero-length directory name in the LD_LIBRARY_PATH via the 'envvars' file. A local attacker with access to that utility could exploit this to load a malicious Dynamic Shared Object (DSO), leading to arbitrary code execution. (CVE-2012-0883)

- An input validation error exists related to 'mod_negotiation', 'Multiviews' and untrusted uploads that can allow cross-site scripting attacks. (CVE-2012-2687)


Upgrade to Apache version 2.2.23 or later.

See Also



Plugin Details

Severity: Medium

ID: 6576

Family: Web Servers

Published: 2012/09/17

Updated: 2019/03/06

Dependencies: 3057

Nessus ID: 62101

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.9

Temporal Score: 5.7

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.4

Temporal Score: 6.9

Vector: CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server:2.2

Patch Publication Date: 2012/09/13

Vulnerability Publication Date: 2012/03/02

Reference Information

CVE: CVE-2012-0883, CVE-2012-2687

BID: 53046, 55131

IAVA: 2015-A-0149