Apache 2.2 < 2.2.23 Multiple Vulnerabilities

high Nessus Network Monitor Plugin ID 6576

Synopsis

The remote web server uses a version of Apache that is affected by multiple vulnerabilities

Description

Apache versions earlier than 2.2.23 are affected by the following vulnerabilities.

- The utility 'apachectl' can receive a zero-length directory name in the LD_LIBRARY_PATH via the 'envvars' file. A local attacker with access to that utility could exploit this to load a malicious Dynamic Shared Object (DSO), leading to arbitrary code execution. (CVE-2012-0883)

- An input validation error exists related to 'mod_negotiation', 'Multiviews' and untrusted uploads that can allow cross-site scripting attacks. (CVE-2012-2687)

Solution

Upgrade to Apache version 2.2.23 or later.

See Also

http://httpd.apache.org/security/vulnerabilities_22.html

https://archive.apache.org/dist/httpd/CHANGES_2.2.23

Plugin Details

Severity: High

ID: 6576

Family: Web Servers

Published: 9/17/2012

Updated: 3/6/2019

Nessus ID: 62101

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.9

Temporal Score: 5.7

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.4

Temporal Score: 6.9

Vector: CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:2.2:*:*:*:*:*:*:*

Patch Publication Date: 9/13/2012

Vulnerability Publication Date: 3/2/2012

Reference Information

CVE: CVE-2012-2687, CVE-2012-0883

BID: 55131, 53046

IAVA: 2015-A-0149