Asterisk Remote Crash Vulnerability in voice mail application (AST-2012-011)

Low Nessus Network Monitor Plugin ID 6511

Synopsis

The remote VoIP server is vulnerable to a denial of service attack.

Description

According to the version in its SIP banner, the version of Asterisk running on the remote host is potentially affected by a vulnerability that could allow a remote attacker to crash the server. If a single voicemail account is manipulated by two parties simultaneously, a condition can occur where memory is freed twice causing a crash.

Solution

Upgrade to Asterisk 1.8.13.1 / 10.5.2

See Also

http://downloads.asterisk.org/pub/security/AST-2012-011.html

http://www.securityfocus.com/bid/54317/info

Plugin Details

Severity: Low

ID: 6511

Family: Generic

Published: 2011/07/09

Modified: 2017/01/31

Dependencies: 3768

Nessus ID: 60065

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 3.5

Temporal Score: 2.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 3

Temporal Score: 2.6

Vector: CVSS3#AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2011/07/05

Vulnerability Publication Date: 2011/07/05

Reference Information

CVE: CVE-2012-3812

BID: 54317