PHP 5.3.x < 5.3.13 CGI Query String Code Execution

high Nessus Network Monitor Plugin ID 6494
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is affected by a code execution vulnerability.

Description

Versions of PHP 5.3.x prior to 5.3.13 are affected by a code execution vulnerability. The fix for CVE-2012-1823 does not completely correct the CGI query vulnerability. Disclosure of PHP source code and code execution via query paramenters are still possible.

Note, this vulnerability is exploitable only when PHP is used by CGI-based configurations. Apache with 'mod-php' is not an exploitable configuration.

Solution

Upgrade to PHP version 5.3.13 or later.

See Also

https://bugs.php.net/bug.php?id=61910

http://www.php.net/archive/2012.php#id2012-05-08-1

http://www.php.net/ChangeLog-5.php#5.3.13

http://eindbazen.net/2012/05/php-cgi-advisory-cve-2012-1823

Plugin Details

Severity: High

ID: 6494

Family: Web Servers

Published: 6/5/2012

Updated: 3/6/2019

Dependencies: 8682

Nessus ID: 59088, 59056

Risk Information

CVSS v2

Risk Factor: High

Base Score: 8.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Patch Publication Date: 5/8/2012

Vulnerability Publication Date: 5/6/2012

Reference Information

CVE: CVE-2012-2336, CVE-2012-2335, CVE-2012-2311

BID: 53388