PHP 5.3.x < 5.3.13 CGI Query String Code Execution

High Nessus Network Monitor Plugin ID 6494


The remote web server uses a version of PHP that is affected by a code execution vulnerability.


Versions of PHP 5.3.x prior to 5.3.13 are affected by a code execution vulnerability. The fix for CVE-2012-1823 does not completely correct the CGI query vulnerability. Disclosure of PHP source code and code execution via query paramenters are still possible.

Note, this vulnerability is exploitable only when PHP is used by CGI-based configurations. Apache with 'mod-php' is not an exploitable configuration.


Upgrade to PHP version 5.3.13 or later.

See Also

Plugin Details

Severity: High

ID: 6494

File Name: 6494.prm

Family: Web Servers

Published: 2012/06/05

Modified: 2016/11/23

Dependencies: 8682

Nessus ID: 59056, 59088

Risk Information

Risk Factor: High


Base Score: 8.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 6.9

Temporal Score: 6.4


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2012/05/08

Vulnerability Publication Date: 2012/05/06

Reference Information

CVE: CVE-2012-2311, CVE-2012-2335, CVE-2012-2336

BID: 53388

OSVDB: 81633, 82213