nginx < 1.0.15 / 1.1.x < 1.1.19 Buffer-Overflow Vulnerability
Medium Nessus Network Monitor Plugin ID 6458
SynopsisThe remote web server is affected by a buffer-overflow vulnerability.
DescriptionThe remote host is running a nginx HTTP server.
Versions earlier than 1.0.15(stable version) or versions earlier than 1.1.19(development version) are vulnerable to a buffer-overflow vulnerability because it fails to perform adequate checks on user-supplied input. An attacker can exploit this issue by using a specially-crafted mp4 file, allowing the attacker to execute arbitrary code in the context of the application. (CVE-2012-2089)
SolutionUpgrade to nginx 1.0.15(stable version) or 1.1.19(development version) or later.