nginx < 1.0.15 / 1.1.x < 1.1.19 Buffer-Overflow Vulnerability

Medium Nessus Network Monitor Plugin ID 6458


The remote web server is affected by a buffer-overflow vulnerability.


The remote host is running a nginx HTTP server.

Versions earlier than 1.0.15(stable version) or versions earlier than 1.1.19(development version) are vulnerable to a buffer-overflow vulnerability because it fails to perform adequate checks on user-supplied input. An attacker can exploit this issue by using a specially-crafted mp4 file, allowing the attacker to execute arbitrary code in the context of the application. (CVE-2012-2089)


Upgrade to nginx 1.0.15(stable version) or 1.1.19(development version) or later.

See Also

Plugin Details

Severity: Medium

ID: 6458

Family: Web Servers

Published: 2012/04/17

Modified: 2016/01/19

Dependencies: 1442

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 5.6

Temporal Score: 4.9


Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Patch Publication Date: 2012/04/12

Vulnerability Publication Date: 2012/04/12

Reference Information

CVE: CVE-2012-2089

BID: 52999