Apache Tomcat 7.0.x < 7.0.22 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 6333

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

Versions of Tomcat 7.0.x earlier than 7.0.22 are potentially affected by multiple vulnerabilities:

- An information disclosure vulnerability exists. Request information is cached in two objects and these objects are not recycled at the same time. Further requests can obtain sensitive information if certain error conditions occur. (CVE-2011-3375)

- The web server is not properly restricting access to the servlets that provide the functionality of the Manager application. This can allow untrusted web applications to access privileged internal functionality such as gathering information on running web applications and deploying additional web applications. (CVE-2011-3376)

Solution

Upgrade to Apache Tomcat 7.0.22 or later.

See Also

http://www.nessus.org/u?4bf28407

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.22

Plugin Details

Severity: Medium

ID: 6333

File Name: 6333.prm

Family: Web Servers

Published: 2012/02/22

Modified: 2016/11/23

Dependencies: 3057

Nessus ID: 57082

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Patch Publication Date: 2011/11/25

Vulnerability Publication Date: 2011/12/28

Reference Information

CVE: CVE-2011-3375, CVE-2011-3376

BID: 50603, 51442