Apache Tomcat 6.0.x < 6.0.33 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 6018

Synopsis

The remote web server is vulnerable to multiple attack vectors.

Description

Versions of Tomcat 6.x earlier than 6.0.33 are potentially affected by multiple vulnerabilities :

- An error handling issue exists related to the MemoryUserDatabase that allows user passwords to be disclosed through log files. (CVE-2011-2204)

- An input validation error exists that allows a local attacker to either bypass security or carry out denial of service attacks when the APR or NIO connectors are enabled. (CVE-2011-2526)

- A component that Apache Tomcat relies on called 'jsvc' contains an error in that it does not drop capabilities after starting and can allow access to sensitive files owned by the super user. Note this vulnerability only affects Linux operating systems and only when the following are true: jsvc is compiled with libpcap and the '-user' parameter is used. (CVE-2011-2729)

Solution

Upgrade to Apache Tomcat 6.0.33 or later.

See Also

http://tomcat.apache.org/security-6.html#Fixed_in_Apache_Tomcat_6.0.33

http://www.nessus.org/u?b56cc2cd

Plugin Details

Severity: Medium

ID: 6018

File Name: 6018.prm

Family: Web Servers

Published: 2011/08/30

Modified: 2016/01/21

Dependencies: 3057

Nessus ID: 56008

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Patch Publication Date: 2011/08/18

Vulnerability Publication Date: 2011/06/27

Reference Information

CVE: CVE-2011-2204, CVE-2011-2526, CVE-2011-2729

BID: 48456, 48667, 49143

OSVDB: 73429, 73797, 73798, 74541