Apple iOS < 4.2.10 / 4.3.x < 4.3.5 Data Security Certificate Verification

High Nessus Network Monitor Plugin ID 5993


The remote host is affected by a security bypass vulnerability.


According to its banner, the remote Apple iOS device is affected by a security bypass vulnerability due to a certificate chain validation issue during the handling of X.509 certificates. Versions of Apple iOS less than version 4.2.10, or 4.3.x prior to 4.3.5 are potentially affected by this security bypass vulnerability.


Upgrade to Apple iOS 4.2.10, 4.3.5, or later.

See Also

Plugin Details

Severity: High

ID: 5993

File Name: 5993.prm

Published: 2011/07/26

Modified: 2016/12/10

Dependencies: 8637

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 7.3

Temporal Score: 6.8


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:apple:iphone_os

Patch Publication Date: 2011/07/25

Vulnerability Publication Date: 2011/07/25

Reference Information

CVE: CVE-2011-0228

BID: 48877

OSVDB: 74030