Flash Player < 10.2.152.33 Unspecified Memory Corruption (APSB11-05)

High Nessus Network Monitor Plugin ID 5827

Synopsis

The remote host contains a browser plugin that is affected by a memory corruption vulnerability.

Description

Versions of Flash Player earlier than 10.2.152.33 are potentially affected by an unspecified memory corruption vulnerability. A remote attacker could exploit this by tricking a user into viewing maliciously crafted SWF content, resulting in arbitrary code. This bug is currently being exploited in the wild.

Solution

Upgrade to Flash Player 10.2.152.33 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb11-05.html

Plugin Details

Severity: High

ID: 5827

Family: Web Clients

Published: 2011/03/22

Modified: 2016/01/19

Dependencies: 5783

Nessus ID: 52673

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2011/03/15

Vulnerability Publication Date: 2011/03/14

Exploitable With

Metasploit (Adobe Flash Player AVM Bytecode Verification)

Reference Information

CVE: CVE-2011-0609

BID: 46860