Apache Tomcat 7.0.x < 7.0.11 Security Bypass Vulnerability

Medium Nessus Network Monitor Plugin ID 5816

Synopsis

The remote web server is affected by security bypass vulnerability.

Description

Versions of Tomcat 7.0.x earlier than 7.0.11 are potentially affected by a security bypass vulnerability. When a web application is started, 'ServletSecurity' annotations might be ignored which could lead to some areas of the application not being protected as expected.

Solution

Upgrade to Apache Tomcat 7.0.11 or later.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.11_(released_11_Mar_2011)

http://mail-archives.apache.org/mod_mbox/www-announce/201103.mbox/%[email protected]%3E

Plugin Details

Severity: Medium

ID: 5816

Family: Web Servers

Published: 2011/03/11

Modified: 2016/11/23

Dependencies: 3057

Nessus ID: 52634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 6.4

Temporal Score: 5.5

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Patch Publication Date: 2011/03/11

Vulnerability Publication Date: 2011/03/02

Reference Information

CVE: CVE-2011-1088, CVE-2011-1419

BID: 46685