Apache Tomcat 6.0.x < 6.0.32 Denial of Service Vulnerability

Medium Nessus Network Monitor Plugin ID 5790

Synopsis

The remote web server is vulnerable to a denial of service attack.

Description

Versions of Tomcat 6.x earlier than 6.0.32 are potentially affected by a denial of service vulnerability because the NIO connector expands its buffer endlessly during request line processing.

Solution

Upgrade to Apache Tomcat 6.0.32 or later.

See Also

http://tomcat.apache.org/security-6.html

Plugin Details

Severity: Medium

ID: 5790

File Name: 5790.prm

Family: Web Servers

Published: 2011/02/11

Modified: 2016/11/23

Dependencies: 3057

Nessus ID: 51987

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Patch Publication Date: 2011/02/03

Vulnerability Publication Date: 2011/11/05

Reference Information

CVE: CVE-2011-0534

BID: 46164

OSVDB: 70809