Apache Tomcat 6.0.x < 6.0.32 Denial of Service Vulnerability

Medium Nessus Network Monitor Plugin ID 5790


The remote web server is vulnerable to a denial of service attack.


Versions of Tomcat 6.x earlier than 6.0.32 are potentially affected by a denial of service vulnerability because the NIO connector expands its buffer endlessly during request line processing.


Upgrade to Apache Tomcat 6.0.32 or later.

See Also


Plugin Details

Severity: Medium

ID: 5790

Family: Web Servers

Published: 2011/02/11

Updated: 2019/03/06

Dependencies: 3057

Nessus ID: 51987

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Patch Publication Date: 2011/02/03

Vulnerability Publication Date: 2011/11/05

Reference Information

CVE: CVE-2011-0534

BID: 46164