Apache Tomcat 5.5.x < 5.5.30 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5786

Synopsis

The remote web server is vulnerable to multiple attack vectors.

Description

Versions of Tomcat 5.x earlier than 5.5.30 are potentially affected by multiple vulnerabilities :

- The 'WWW-Authenticate' HTTP header for BASIC and DIGEST authentcation may expose the local host name or IP address of the machine running Tomcat. (CVE-2010-1157)

- Several flaws in the handling of the 'Tansfer-Encoding' header could prevent the recycling of buffer. (CVE-2010-2227)

- When running under a SecurityManager, it is possible for web applications to be granted read/write permissions to any area on the file system. (CVE-2010-3718)

Solution

Upgrade to Apache Tomcat 5.5.30 or later.

See Also

http://tomcat.apache.org/security-5.html

Plugin Details

Severity: Medium

ID: 5786

File Name: 5786.prm

Family: Web Servers

Published: 2011/02/11

Modified: 2017/02/02

Dependencies: 3057

Nessus ID: 47749

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:W/RC:ND

CVSSv3

Base Score: 5.3

Temporal Score: 5

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:F/RL:W/RC:X

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Patch Publication Date: 2011/01/13

Vulnerability Publication Date: 2010/11/22

Reference Information

CVE: CVE-2010-1157, CVE-2010-2227, CVE-2010-3718

BID: 39635, 41544, 46177

OSVDB: 64023, 66319

IAVA: 2011-A-0066