PostgreSQL < 9.0.3 / 8.4.7 / 8.3.14 / 8.2.20 Code Execution Vulnerability

Medium Nessus Network Monitor Plugin ID 5757


The remote database server is affected by a buffer overflow vulnerability.


Versions of PostgreSQL earlier than 9.0.3, 8.4.7, 8.3.14, or 8.2.20 are potentially affected by a buffer overflow vulnerability in the contrib module intarray's input function for the query_int type. An attacker, exploiting this flaw, could potentially execute arbitrary code on the remote host subject to the privileges of the user running the affected application.


Upgrade to PostgreSQL 9.0.3, 8.4.7, 8.3.14, 8.2.20, or later.

See Also

Plugin Details

Severity: Medium

ID: 5757

File Name: 5757.prm

Family: Database

Published: 2011/02/02

Modified: 2016/01/21

Dependencies: 8704, 8705

Risk Information

Risk Factor: Medium


Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 6.3

Temporal Score: 5.5


Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2011/01/31

Vulnerability Publication Date: 2011/02/01

Reference Information

CVE: CVE-2010-4015

BID: 46084