Adobe Flash Media server < 3.0.7 / 3.5.5 / 4.0.1 Multiple Vulnerabilities (APSB10-27)

High Nessus Network Monitor Plugin ID 5704

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running Adobe Flash Media Server.

Versions of Adobe Flash Media Server earlier than 3.0.7, 3.5.5, or 4.0.1 are potentially affected by multiple vulnerabilities :

- The server is vulnerable to a denial of service attack due to an unspecified memory leak error. (CVE-2010-3633)

- The server is vulnerable to a denial of service attack due to an unspecified error in the server's 'edge process'. (CVE-2010-3634)

- An unspecified error exists which can allow an attacker to cause a segmentation fault and may lead to arbitrary code execution. (CVE-2010-3635)

Solution

Upgrade to Flash Media Server 3.0.7, 3.5.5, 4.0.1, or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb10-27.html

Plugin Details

Severity: High

ID: 5704

Family: Web Servers

Published: 2010/11/10

Modified: 2016/01/15

Dependencies: 4378, 4379

Nessus ID: 50562

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2010/11/09

Vulnerability Publication Date: 2010/11/09

Reference Information

CVE: CVE-2010-3633, CVE-2010-3634, CVE-2010-3635

BID: 44753, 44756, 44757