Adobe Flash Media server < 3.0.7 / 3.5.5 / 4.0.1 Multiple Vulnerabilities (APSB10-27)
High Nessus Network Monitor Plugin ID 5704
SynopsisThe remote host is vulnerable to multiple attack vectors.
DescriptionThe remote host is running Adobe Flash Media Server.
Versions of Adobe Flash Media Server earlier than 3.0.7, 3.5.5, or 4.0.1 are potentially affected by multiple vulnerabilities :
- The server is vulnerable to a denial of service attack due to an unspecified memory leak error. (CVE-2010-3633)
- The server is vulnerable to a denial of service attack due to an unspecified error in the server's 'edge process'. (CVE-2010-3634)
- An unspecified error exists which can allow an attacker to cause a segmentation fault and may lead to arbitrary code execution. (CVE-2010-3635)
SolutionUpgrade to Flash Media Server 3.0.7, 3.5.5, 4.0.1, or later.