QuickTime < 7.6.7 QuickTimeStreaming.qtx SMIL File Debug Logging Overflow (Windows) (deprecated)

Medium Nessus Network Monitor Plugin ID 5628

Synopsis

The remote host contains an application that is affected by a stack overflow vulnerability.

Description

Versions of QuickTime earlier than 7.6.7 are potentially affected by a stack overflow in the application's error logging when debug logging is enabled. If an attacker can trick a user on the host into viewing a specially crafted movie file, he may be able to cause an application crash or even execute arbitrary code subject to the user's privileges. Note that this issue only affects QuickTime on Windows.

Solution

Upgrade to QuickTime 7.6.7 or later.

See Also

http://support.apple.com/kb/HT4290

http://lists.apple.com/archives/security-announce/2010/aug/msg00002.html

Plugin Details

Severity: Medium

ID: 5628

File Name: 5628.prm

Family: Web Clients

Published: 2010/08/13

Modified: 2016/01/19

Dependencies: 1735, 8314

Nessus ID: 48323

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2010/08/12

Vulnerability Publication Date: 2010/07/27

Exploitable With

CANVAS (White_Phosphorus)

Core Impact

Metasploit (Apple QuickTime 7.6.6 Invalid SMIL URI Buffer Overflow)

Reference Information

CVE: CVE-2010-1799

BID: 41962