Adobe Flash Media server < 3.0.6 / 3.5.4 Multiple Vulnerabilities (APSB10-19)

High Nessus Network Monitor Plugin ID 5624

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running Adobe Flash Media Server.

Versions of Adobe Flash Media Server earlier than 3.0.6 / 3.5.4 are potentially affected by multiple vulnerabilities :

- An issue in a JS method could result in a denial of service condition. (CVE-2010-2218)

- An issue in a JS method could allow arbitrary code execution. (CVE-2010-2217)

- A memory exhaustion issue could lead to a denial of service condition. (CVE-2010-2219)

- An input validation issue could lead to a denial of service condition. (CVE-2010-2220)

Solution

Upgrade to Flash Media Server 3.0.6, 3.5.4, or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb10-19.html

Plugin Details

Severity: High

ID: 5624

File Name: 5624.prm

Family: Web Servers

Published: 2010/08/11

Modified: 2016/11/23

Dependencies: 4378, 4379

Nessus ID: 48298

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2010/08/10

Vulnerability Publication Date: 2010/08/10

Reference Information

CVE: CVE-2010-2217, CVE-2010-2218, CVE-2010-2219, CVE-2010-2220

BID: 42352, 42354, 42356, 42357