Zabbix 1.8.x < 1.8.2 'DBCondition' Parameter SQL Injection

High Nessus Network Monitor Plugin ID 5519

Synopsis

The remote host is running a web application that is vulnerable to a SQL-injection attack.

Description

The remote host is running Zabbix, an IT monitoring service. The installed version of Zabbix is earlier than 1.8.2. Such versions are potentially affected by a SQL-injection vulnerability in the 'user' parameter of the 'api.jsonrpc.php' script. A remote, unauthenticated attacker could exploit this flaw to gain control of the affected application.

Solution

Upgrade to Zabbix 1.8.2 or later.

See Also

http://www.zabbix.com/rn1.8.2.php

http://www.securityfocus.com/archive/1/510480/100/0/threaded

Plugin Details

Severity: High

ID: 5519

File Name: 5519.prm

Family: Generic

Published: 2010/04/27

Modified: 2016/01/15

Dependencies: 1442

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:zabbix:zabbix:1.8

Patch Publication Date: 2010/04/01

Vulnerability Publication Date: 2010/04/01

Reference Information

CVE: CVE-2010-1277

BID: 39148

OSVDB: 63456