Adobe Flash Media Server < 3.0.5 / 3.5.3 Multiple Vulnerabilities (APSB09-018) (RTMP over HTTP)

High Nessus Network Monitor Plugin ID 5283

Synopsis

The remote host is vulnerable to multiple attack vectors

Description

The remote host is running Adobe Flash Media server. The installed version of Adobe Flash Media server appears to be earlier than 3.0.5 or 3.5.3. Such versions are potentially affected by multiple vulnerabilities :

- A resource exhaustion vulnerability that could lead to a denial of service. (CVE-2009-3791)

- A directory traversal vulnerability that could lead to FMS loading arbitrary DLLs present on the server. (CVE-2009-3792)

Solution

Upgrade to Adobe Flash Media Server 3.0.5, 3.5.3 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb09-18.html

Plugin Details

Severity: High

ID: 5283

File Name: 5283.prm

Family: Web Servers

Published: 2009/12/22

Modified: 2016/01/15

Dependencies: 4378, 4379

Nessus ID: 43390

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2009/12/18

Vulnerability Publication Date: 2009/12/18

Reference Information

CVE: CVE-2009-3791, CVE-2009-3792

BID: 37419, 37420

OSVDB: 61241, 61242