PostgreSQL < 8.4.2 / 8.3.9 / 8.2.15 / 8.1.19 / 8.0.23 / 7.4.27 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5261

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running a version of PostgreSQL that is earelir than 8.4.2, 8.3.9, 8.2.15, 8.1.19, 8.0.23, or 7.4.27. Such versions are potentially affected by multiple vulnerabilities :

- NULL Bytes in SSL Certificates can be used to falsify client or server authentication. (CVE-2009-4034)

- Privilege escalation via changing session state in an index function. (CVE-2009-4136) - An integer overflow in the 'ExecChooseHashTableSize()' function of the 'backend/executor/nodeHash.c' source file which could lead to a denial of service. (CVE-2010-0733)

Solution

Upgrade to PostgreSQL 7.4.27, 8.0.23, 8.1.19, 8.2.15, 8.3.9, 8.4.2, or later.

See Also

http://www.postgresql.org/support/security

Plugin Details

Severity: Medium

ID: 5261

Family: Database

Published: 2009/12/15

Modified: 2016/01/21

Dependencies: 8703, 8704

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.4

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 6.5

Temporal Score: 6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2009/12/14

Vulnerability Publication Date: 2009/12/14

Reference Information

CVE: CVE-2009-4034, CVE-2009-4136, CVE-2010-0733

BID: 37333, 37334, 38619