PostgreSQL < 8.4.2 / 8.3.9 / 8.2.15 / 8.1.19 / 8.0.23 / 7.4.27 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 5261
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote host is vulnerable to multiple attack vectors.


The remote host is running a version of PostgreSQL that is earelir than 8.4.2, 8.3.9, 8.2.15, 8.1.19, 8.0.23, or 7.4.27. Such versions are potentially affected by multiple vulnerabilities :

- NULL Bytes in SSL Certificates can be used to falsify client or server authentication. (CVE-2009-4034)

- Privilege escalation via changing session state in an index function. (CVE-2009-4136) - An integer overflow in the 'ExecChooseHashTableSize()' function of the 'backend/executor/nodeHash.c' source file which could lead to a denial of service. (CVE-2010-0733)


Upgrade to PostgreSQL 7.4.27, 8.0.23, 8.1.19, 8.2.15, 8.3.9, 8.4.2, or later.

See Also

Plugin Details

Severity: Medium

ID: 5261

Family: Database

Published: 12/15/2009

Updated: 3/6/2019

Dependencies: 8703, 8704

Risk Information


Risk Factor: Medium

Base Score: 6.4

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Risk Factor: Medium

Base Score: 6.5

Temporal Score: 6.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:*

Patch Publication Date: 12/14/2009

Vulnerability Publication Date: 12/14/2009

Reference Information

CVE: CVE-2009-4136, CVE-2010-0733, CVE-2009-4034

BID: 37333, 37334, 38619