Oracle MySQL < 5.1.41 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5240

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The remote host is running MySQL Community server &lt; 5.1.41. Such versions are potentially affected by multiple issues :

- The application fails to correctly handle the data directory path name if it contains symlinked directories in its path which could lead to a local privilege escalation. (Bug 32167)

- MySQL clients linked against OpenSSL did not check server certificates presented by a server linked against yaSSL. (Bug 47320)

- An error related to the handling of certain SELECT statements containing subqueries.

- A failure to preserve unspecified 'null_value' flags when executing statements that use the 'GeomFromWKB' function.

Solution

Upgrade to MySQL Community server 5.1.41 or later.

See Also

http://bugs.mysql.com/bug.php?id=39277

http://bugs.mysql.com/bug.php?id=47320

http://bugs.mysql.com/bug.php?id=47780

http://bugs.mysql.com/bug.php?id=48291

http://dev.mysql.com/doc/refman/5.1/en/news-5-1-41.html

Plugin Details

Severity: High

ID: 5240

Family: Database

Published: 2009/11/24

Modified: 2016/01/15

Dependencies: 5003

Nessus ID: 42900

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Patch Publication Date: 2009/11/05

Vulnerability Publication Date: 2009/11/19

Reference Information

CVE: CVE-2008-2079, CVE-2009-4019

BID: 37075, 37076, 37297