CUPS < 1.4.2 XSS

Medium Nessus Network Monitor Plugin ID 5230

Synopsis

The remote host is running a web application that is affected by a cross-site scripting vulnerability.

Description

According to its banner, the version of CUPS installed on the remote host is earlier than 1.4.2. Such versions are potentially affected by a cross-site scripting vulnerability because the application fails to properly sanitize the 'kerberos' parameter.

Solution

Upgrade to CUPS version 1.4.2 or later.

See Also

http://www.cups.org/articles.php?L590

Plugin Details

Severity: Medium

ID: 5230

Family: Web Servers

Published: 2009/11/11

Modified: 2016/01/21

Dependencies: 1442

Nessus ID: 42468

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 4.8

Temporal Score: 4.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2009/11/10

Vulnerability Publication Date: 2009/11/10

Reference Information

CVE: CVE-2009-2820

BID: 36958