SVN < 1.5.6 / 1.6.0-1.6.3 Multiple Integer Overflows (deprecated)

High Nessus Network Monitor Plugin ID 5140

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The installed version of SVN is affected by multiple heap overflow issues. Specifically, the 'libsvn_delta' library fails to perform sufficient boundary checks before processing certain svndiff streams. An attacker with commit access to a vulnerable Subversion server could exploit this vulnerability from a Subversion client to trigger a heap overflow on the server. Typically such an attack would result in a denial of service condition or arbitrary code execution. An attacker could also trigger this issue from a rogue Subversion server on a Subversion client in response to a checkout or update request.

Solution

Upgrade to SVN 1.5.7/1.6.4 or later.

See Also

http://svn.haxx.se/dev/archive-2009-08/0107.shtml

http://svn.haxx.se/dev/archive-2009-08/0108.shtml

http://subversion.tigris.org/security/CVE-2009-2411-advisory.txt

Plugin Details

Severity: High

ID: 5140

Family: Generic

Published: 2009/08/25

Updated: 2019/03/06

Nessus ID: 40620

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2009/08/06

Vulnerability Publication Date: 2009/08/06

Reference Information

CVE: CVE-2009-2411

BID: 35983