SeaMonkey < 1.1.17 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 5084
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is running a web browser that is vulnerable to multiple attack vectors.

Description

The remote host is running a version of SeaMonkey earlier than 1.1.17. Such versions are reportedly affected by multiple vulnerabilities :

- Multiple remote memory-corruption vulnerabilities.

- Content injection vulnerabilities.

- An information disclosure vulnerability.

- A cross-site scripting vulnerability.

- A privilege escalation vulnerability.

- A security bypass vulnerability.

- A URI spoofing vulnerability.

Solution

Upgrade to SeaMonkey 1.1.17 or later.

See Also

http://www.mozilla.org/security/announce

Plugin Details

Severity: Medium

ID: 5084

Family: Web Clients

Published: 8/18/2004

Updated: 3/6/2019

Dependencies: 3538

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mozilla:seamonkey:*:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2009-0652, CVE-2009-1303, CVE-2009-1305, CVE-2009-1306, CVE-2009-1307, CVE-2009-1309, CVE-2009-1311, CVE-2009-1312, CVE-2009-1302, CVE-2009-1304, CVE-2009-1308, CVE-2009-1310, CVE-2009-1392, CVE-2009-1832, CVE-2009-1833, CVE-2009-1834, CVE-2009-1838, CVE-2009-1840, CVE-2009-1841, CVE-2009-2210

BID: 35372, 35383, 35461, 34656, 35371, 35373, 35377, 35388