Google Chrome < 2.0.172.31 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 5049
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains a web browser that is vulnerable to multiple attack vectors.

Description

The version of Google Chrome installed on the remote host is earlier than 2.0.172.31. Such versions are reportedly affected by multiple issues :

- A memory corruption issue exists in the way the WebKit handles recursion in certain DOM event handlers. (CVE-2009-1690)

- WebKit's handling of drag events is affected by an information disclosure vulnerability. (CVE-2009-1718)

Solution

Upgrade to Google Chrome 2.0.172.31 or later.

See Also

http://googlechromereleases.blogspot.com/2009/06/stable-update-2-webkit-security-fixes.html

Plugin Details

Severity: Medium

ID: 5049

Family: Web Clients

Published: 8/18/2004

Updated: 3/6/2019

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2009-1690, CVE-2009-1718

BID: 35271, 35272, 35283