Winamp < 5.552 Buffer Overflow

Medium Nessus Network Monitor Plugin ID 5031

Synopsis

The remote host is vulnerable to a buffer overflow

Description

The remote host is running Winamp, a media player for Windows. The version of Winamp installed on the remote host is earlier than 5.552. Such versions reportedly contain a flaw in the way that it handles malformed '.maki' files. A malfored file will cause a buffer overflow within the 'gen_ff.dll' library. Successful exploitation will result in the attacker executing arbitrary code. An attacker, exploiting this flaw, would need to be able to entice a user into opening a malformed '.maki' file.

Solution

Upgrade to Winamp version 5.552 or later.

See Also

http://vrt-sourcefire.blogspot.com/2009/05/winamp-maki-parsing-vulnerability.html

Plugin Details

Severity: Medium

ID: 5031

Family: Generic

Published: 2004/08/18

Modified: 2018/09/16

Dependencies: 1735, 8314

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS3#AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:nullsoft:winamp

Exploitable With

Metasploit (Winamp MAKI Buffer Overflowcore=true)

Reference Information

CVE: CVE-2009-1831

BID: 35052