phpMyAdmin < 3.1.3.2 Multiple RCE (PMASA-2009-4)

high Nessus Network Monitor Plugin ID 4997
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server contains a PHP application that may allow execution of arbitrary code

Description

The setup script included with the version of phpMyAdmin installed on the remote host does not properly sanitize user-supplied input before using it to generate a config file for the application. This version has the following vulnerabilities :

- The setup script inserts the unsanitized verbose server name into a C-style comment during config file generation.

- An attacker can save arbitrary data to the generated config file by altering the value of the 'textconfig' parameter during a POST request to config.php. An unauthenticated remote attacker may be able to leverage these issues to execute arbitrary PHP code.

Solution

Upgrade to version 3.1.3.2 or apply the patches referenced in the project's advisory.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2009-4.php

Plugin Details

Severity: High

ID: 4997

Family: CGI

Published: 4/17/2009

Updated: 3/6/2019

Dependencies: 9102

Nessus ID: 36171

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2009-1285

BID: 34526