CVE-2009-1285

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Static code injection vulnerability in the getConfigFile function in setup/lib/ConfigFile.class.php in phpMyAdmin 3.x before 3.1.3.2 allows remote attackers to inject arbitrary PHP code into configuration files.

References

http://phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin/branches/MAINT_3_1_3/phpMyAdmin/setup/lib/ConfigFile.class.php?r1=12248&r2=12301&pathrev=12342

http://secunia.com/advisories/34727

http://secunia.com/advisories/34741

http://www.phpmyadmin.net/home_page/security/PMASA-2009-4.php

http://www.securityfocus.com/bid/34526

http://www.vupen.com/english/advisories/2009/1045

https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00442.html

https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00452.html

Details

Source: MITRE

Published: 2009-04-16

Updated: 2009-04-28

Type: CWE-94

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Tenable Plugins

View all (5 total)

IDNameProductFamilySeverity
36312Fedora 10 : phpMyAdmin-3.1.3.2-1.fc10 (2009-3700)NessusFedora Local Security Checks
high
4997phpMyAdmin < 3.1.3.2 Multiple RCE (PMASA-2009-4)Nessus Network MonitorCGI
high
36171phpMyAdmin Setup Script Configuration Parameters Arbitrary PHP Code Injection (PMASA-2009-4)NessusCGI abuses
high
36167FreeBSD : phpmyadmin -- insufficient output sanitizing when generating configuration file (1a0e4cc6-29bf-11de-bdeb-0030843d3802)NessusFreeBSD Local Security Checks
high
36165Fedora 9 : phpMyAdmin-3.1.3.2-1.fc9 (2009-3692)NessusFedora Local Security Checks
high