Apache TomCat mod_jk < 1.2.27 Cross-user Information Disclosure

Medium Nessus Network Monitor Plugin ID 4984

Synopsis

The remote host is vulnerable to a flaw that allows attackers to retrieve sensitive files or data.

Description

The remote host is running the Apache Tomcat web server with mod_jk

. mod_jk is reported vulnerable to an information disclosure flaw due to the way that it processes 'Content-Length' headers. Allegedly, an attacker supplying a NULL content-length can view the HTTP responses of other requests. An attacker exploiting this flaw would be able to possibly gain access to confidential data.

Solution

Upgrade to version 1.2.27 or higher.

See Also

http://tomcat.apache.org/download-connectors.cgi

Plugin Details

Severity: Medium

ID: 4984

Family: Web Servers

Published: 2009/04/08

Modified: 2018/09/16

Dependencies: 3057

Nessus ID: 46885

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Reference Information

CVE: CVE-2008-5519

BID: 34412