iTunes < 8.1 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 4958

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

According to its banner, the version of iTunes installed on the remote host is older than 8.1.

Such versions may be affected by multiple vulnerabilities :

- It may be possible to cause a denial of service by sending a maliciously crafted DAAP header to the application. Note that this flaw only affects iTunes running on a Windows host. (CVE-2009-0016)

- When subscribing to a podcast an authentication dialog may be presented without clarifying the origin of the authentication request. An attacker could exploit this flaw in order to steal the user's iTunes credentials. (CVE-2009-0143)");

Solution

Upgrade to version 8.1 or higher.

See Also

http://support.apple.com/kb/HT3487

Plugin Details

Severity: Medium

ID: 4958

Family: Web Clients

Published: 2009/03/12

Modified: 2018/09/16

Dependencies: 1735, 8314

Nessus ID: 35914

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 6.4

Temporal Score: 5.5

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apple:itunes

Reference Information

CVE: CVE-2009-0143, CVE-2009-0016

BID: 34094