Flash Player APSB09-01 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 4937

Synopsis

The remote Windows host contains a browser plugin that is affected by multiple vulnerabilities.

Description

The remote Windows host contains a version of Adobe Flash Player that is earlier than 10.0.22.87 / 9.0.159.0. Such versions are reportedly affected by multiple vulnerabilities :

- A buffer overflow issue that could allow an attacker to execute arbitrary code with the privileges of the user running the application. (CVE-2009-0520)

- An input validation vulnerability that leads to a denial of service attack and could possibly allow for an attacker to execute arbitrary code. (CVE-2009-0519)

- A vulnerability in the Flash Player settings manager that could contribute to a clickjacking attack. (CVE-2009-0014)

- A vulnerability with the mouse pointer display that could contribute to a clickjacking attack. (CVE-2009-0522)

Solution

Upgrade to version 10.0.22.87 or higher. If you are unable to upgrade to version 10, upgrade to version 9.0.159.0 or higher.

See Also

http://labs.idfense.com/intelligence/vulnerabilities/display.php?id=773

Plugin Details

Severity: Medium

ID: 4937

File Name: 4937.prm

Family: Web Clients

Published: 2009/02/24

Modified: 2016/01/19

Dependencies: 1735, 8314

Nessus ID: 35742

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Reference Information

CVE: CVE-2009-0520, CVE-2009-0114, CVE-2009-0519, CVE-2009-0522

BID: 33890, 33880