ClamAV < 0.93.0 Multiple Overflows (deprecated)

High Nessus Network Monitor Plugin ID 4465

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running ClamAV client.

This version of ClamAV is vulnerable to several flaws due to the way that it parses user-supplied input. It has been reported that there is a heap overflow within the 'libclamav/pe.c' file. An attacker exploiting these flaws would either crash the service or execute arbitrary code on the remote machine.

Solution

Upgrade to version 0.93.0 or higher.

See Also

http://secunia.com/secunia_research/2008-11/advisory

Plugin Details

Severity: High

ID: 4465

Family: Web Clients

Published: 2008/04/15

Modified: 2016/01/15

Dependencies: 1735, 8314

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Reference Information

CVE: CVE-2008-1100, CVE-2008-1387, CVE-2008-1833, CVE-2008-0314, CVE-2008-1835, CVE-2008-1836, CVE-2008-1837

BID: 28784, 28756, 28798, 28782