Lighttpd < 1.4.19 Information Disclosure

Medium Nessus Network Monitor Plugin ID 4411

Synopsis

The remote web server can be manipulated to disclose source code.

Description

The remote host is running Lighttpd, a small web server. This version of Lighttpd is vulnerable to an information disclosure flaw. The 'mod_cgi' module, when put under a considerable load, could fail to fork its process. Such a failure would lead to the web server returning the source code of the CGI script that had been requested. An attacker exploiting this flaw would be able to gain access to potentially confidential data.

Solution

Upgrade to version 1.4.19 or higher.

See Also

http://www.lighttpd.net

Plugin Details

Severity: Medium

ID: 4411

Family: Web Servers

Published: 2008/03/05

Modified: 2016/01/21

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Reference Information

CVE: CVE-2008-1270, CVE-2008-1111

BID: 28100, 28226